• Jay

Avid Doesn't Play Nice with RME

…or at least my Mulitface. I know there’s admitted support for RME’s MADI stuff.

I have a few projects coming up and am considering moving more and more of my editing over to Avid Media Composer. Again, $295 for non-profits through Academic Superstore. There are a variety of reasons I want to do this but two of them being:

  1. Editing is easy and fast on MC4

  2. My online Cineform masters (PPro Cs4 blows).

I just finished up two shorts and screened them this last weekend at a local church. They were edited on Avid on my MBP at home, online’d to Cineform files, AE’d, Nuendo’d and graded, then presented in Cineform masters. They looked stunning and played back on the laptop flawlessly. Several compliments from the church staff that this was the best looking stuff they’ve ever had out of that projector.

In a nutshell, it’s a workflow I’m going to keep because it works really, really well and looks stunning when finished. But I’d like to edit on Avid on my MacPro. I can’t because I use the RME Multiface as my primary audio D/A. I’m left with three options:

  1. Continue to only edit on my MBP

  2. Research and purchase and new D/A interface

  3. Dual boot to a second version of OSX sans RME drivers?

Honestly, 1 and 3 look the most promising. My Mulitface is yes, old, but it works great and has no issues. Option 1 seems doable since my MacPro is an online machine for the most part anyway and I don’t do EVERY project in Avid…just most (with a couple big ones coming). 3 intrigues me because it’s totally doable but then I have no way to listen to anything although a small set of Foxtex monitors or something out of the headphone jack would work.

I’ll update as I research and figure stuff out.

0 views

©2019 by Jay Friesen.

  • Black Instagram Icon
  • Black Flickr Icon